1970s 1976 – XMODEM a point-to-point binary transfer protocol by Ward Christensen. February 1978 – Ward Christensen's CBBS becomes the first Bulletin board system. February 16, 1978 BBS access is limited to phone lines until the early 1990s. 1979 – Usenet conceived by Tom Truscott and Jim Ellis at the University of North Carolina at Chapel Hill and Duke University.From Usenet to CoWebs: interacting with social information spaces, Christopher Lueg, Danyel Fisher, Springer (2003), , Its primary purpose is to facilitate focused discussion threads within topical categories (Usenet newsgroups), but it also allows the transfer of files. alt.binaries.* newsgroups continue to serve files.
1980s Most file sharing in this era was done by modem over landline telephone, at speeds from 300 to 9600 bits per second. Many file systems in use only supported short filenames. Computer memory and speed was very limited, with 33 MHz CPUs only being accessible to consumers at the end of the decade.
1981 – Kermit (protocol) – a binary protocol that can be used with telnet or other BBS systems to transfer binary data. January 1984 – In Sony Corp. of America v. Universal City Studios, Inc., the Supreme Court of the United States finds that making individual copies of complete television shows for purposes of time-shifting is fair use. This case would create some interpretative challenges to courts in applying the case to more recent file sharing technologies available for use on home computers and over the Internet. 1984 – Fidonet, an inter-BBS protocol that became widely available, is founded by Tom Jennings. October 1985 – File Transfer Protocol is standardized in RFC 959, authored by Postel and Reynolds, which made the preceding RFC 765 (and earlier FTP RFCs back to the original RFC 114) obsolete. FTP allows files to be efficiently uploaded and downloaded from a central server. 1985 – Ymodem – a minor improvement to Xmodem. 1986 – Zmodem – another point-to-point binary transfer protocol, which had superior long-distance (high latency) transmission. August 1988 – Internet Relay Chat is created by Jarkko Oikarinen.
1990s FTP, IRC and Usenet were the main vehicles for file sharing in this decade. Data compression technologies for audio and video (like MP3, AAC and MPEG) came into use towards the end of the 1990s. Copper wire was common with fibre optic cable only becoming available late in the decade.
1990 – Michael Sandrof adds Client-to-client protocol functionality to IRC client ircII allowing users to share files. November 1990 – The World Wide Web is formally proposed by Tim Berners-Lee and Robert Cailliau. December 1991 – The Moving Picture Experts Group chooses an audio codec developed by Karlheinz Brandenburg and his colleagues at Fraunhofer Society with input from AT&T and Thomson to serve as the MPEG-1 Audio Layer 3 (MP3) ISO/IEC standard. This allows songs on CDs to be converted into small computer files. June 1992 – RFC 1341 establishes the Multipurpose Internet Mail Extensions(MIME) standards for sending audio and images by email, paving the way for the alt.binaries hierarchy on Usenet. 1992 – Software Publishers Association runs an anti-copyright infringement campaign Don't Copy That Floppy July 1994 – The Fraunhofer Society released the l3enc mp3 encoding software as shareware, the first of its kind. September 1995 – The Fraunhofer Society released WinPlay3, the first software mp3 player for Windows. June 1996 – Mp3 warez group Rabid Neurosis founded. Using connections inside record companies, they rip pre-release music CDs, and make the mp3's available for others to download.Stephen Witt. 2015. How Music Got Free: The End of an Industry, the Turn of the Century, and the Patient Zero of Piracy. Viking. . Mirabilis developed ICQ a chat client for Windows that can do file transfers up to 2 GBs. 1997 – Scour Inc. is founded by five UCLA Computer Science students. Early products provide file search and download using the SMB protocol, as well as a multimedia web search engine released in 1998. Scour attracted early attention and support from media industry insiders before declaring bankruptcy in October 2000. April 1997 – Winamp audio player is released,April 21, 1997 release date extracted from Winamp.exe 0.20a binary. including the ability to make playlists, leading to increased use of MP3 files. May 1997 – AOL launches AOL Instant Messenger with file transfer capabilities. August 1997 – Hotline is announced at MacWorld, and allows chat, forums, and file transfers. It becomes popular among Mac users. September 1997 – Windows Media Player 6.1 includes support for mp3 playback for the first time. November 1997 – MP3.com is founded by Michael Robertson and Greg Flores. Initially an FTP search engine, MP3.com becomes a hosting service for unsigned artists. It serves 4 million audio file downloads per day at its peak and becomes the largest technology IPO in July 1999. The release of My.MP3.com in January 2000, which allowed users to stream their own files, would prompt litigation. In May 2000, UMG v. MP3.com would be ruled in favor of the record labels. MP3.com would settle for $200 million and discontinue the service. January 1998 – Musicmatch Jukebox is released providing easier to use CD-ripping software for creating mp3's on Windows. March 1998 – The MPMan F10, the first portable MP3 player, is launched. July 1998 – SoundJam MP released allowing mp3 playback and CD-ripping on Macintosh computers. In 2000, Apple bought this program, and used it as the basis for iTunes. September 1998 – Rio PMP300 MP3 player is shipped by Diamond Multimedia. Its popularity leads the RIAA to file a temporary restraining order in October, without success. October 1998 – Digital Millennium Copyright Act is unanimously passed by the US Senate. DMCA provides a 'safe harbor' ensuring that Internet Service Providers cannot be sued for the activities of their users. November 1998 – Audiogalaxy is created by Michael Merhej. Initially an FTP search engine, the Audiogalaxy Satellite P2P client would reach 1 million downloads in 2001. In May 2002, a suit by the RIAA would force Audiogalaxy to block sharing of illegal songs. In June 2002, Audiogalaxy would settle the suit for an undisclosed amount and make its services opt-in. In September 2002, Audiogalaxy would discontinue P2P services in favor of Rhapsody, a pay streaming service. December 1998 – MP3 Newswire, the first digital media news site, is launched. February 1999 – China's Tencent launches QQ, a chat client with file transfer capability. June 1999 – Napster was created by Shawn Fanning. Napster let users search across all users' shares. Napster provided a centralized server that indexed the files, and carried out the searches. Individual files, however, remain on the hosts' computers and were transferred directly from peer to peer. November 1999 - The Direct Connect network is created. November 1999 – iMesh is launched. December 1999 – The first lawsuits were filed against Napster.
2000s In computer science terms, modern file sharing begins in the 2000s. Several file sharing protocols and file formats were introduced, along with nearly a decade in protocol experimentation. Towards the end of the 2000s, BitTorrent became subject to a "man in the middle" attack in TCP mode – and this has led most file sharing protocols to move to UDP towards the very end of the decade. Client and tracker software in this era was in development as much as the transmission protocols, so the file trading software was not always as reliable as it could have been.
2000 January – My.MP3.com is released by MP3.com. March – Scour Exchange is released as a P2P file exchange service to compete with Napster. In addition to audio files, it also supports sharing of other media as well as software. March – Gnutella becomes the first decentralized file sharing network with the release of a network client by Justin Frankel and Tom Pepper of Nullsoft. Like Napster, users could share large numbers of files at once, and search across the entire network for files. March – Phex (formerly FURI) Gnutella client released. May – UMG v. MP3.com causes My.MP3.com to shut down. MSN Messenger 3.0 becomes the first version to include file transfer capability. June – Slyck.com (originally Slyway.com) launches. July – Freenet is created by Ian Clarke. Its goal is to provide freedom of speech through a peer-to-peer network which focuses on protecting anonymity. Files are distributed across the computers of Freenet's users. Ian Clarke's paper would become the most-cited computer science paper of 2000. Freenet would become a darknet in 2008. September – eDonkey2000 client and server software is released by Jed McCaleb, introducing hashing into decentralized file sharing. October – Scour Exchange is shut down as Scour Inc. files for bankruptcy in the face of copyright infringement litigation. October – Napster is credited with driving Radiohead's Kid A album to the top of the Billboard charts. December – Peer-to-peer file sharing client WinMX 1.8 beta is released, providing users with another way to connect to Napster (later OpenNap) networks. December – Bearshare was launched as a Gnutella-based peer-to-peer file sharing application.
2001 February – A&M Records, Inc. v. Napster, Inc. February – Napster peaks at 26.4 million users. March – Kazaa and the FastTrack proprietary protocol are released by Niklas Zennström, Janus Friis, and Priit Kasesalu. The Kazaa Media Desktop client came bundled with malware. Legal action in the Netherlands would force an offshoring of the company, renamed Sharman Networks. In September 2003, the RIAA would file suit against private individuals allegedly sharing files via Kazaa. In September 2005, UMA v. Sharman would be ruled against Sharman by the Federal Court of Australia. Sharman's non-compliance would prompt censorship of the program in Australia. In July 2006, the MGM Studios, Inc. v. Grokster, Ltd. would cause Sharman to settle for $100 million and convert Kazaa to a legal-only file sharing program. April – Morpheus is released by MusicCity (later StreamCast), after licensing the FastTrack protocol. MusicCity had previously operated OpenNap servers. Morpheus would become a popular FastTrack client, with 4.5 million users, until licensing disputes and a protocol switch in February 2002. In March 2003, the Morpheus client was re-released to operate on Gnutella, using Gnucleus servant as its core. In June 2005, a redesigned Morpheus client would be released. In June 2005, MGM Studios, Inc. v. Grokster, Ltd. would be decided against StreamCast. In June 2008, the Morpheus client would become no longer available for download. April – gtk-gnutella client is released. July – Napster shuts down due to injunction. Many former Napster users move to OpenNap servers. July – Audiogalaxy Satellite client reaches 1 million downloads. July 2 – BitTorrent released by Bram Cohen. Users only upload one or a small number of files at a time, but all peers are forced to seed to other peers from the parts of a file they have received so far. Initially, programs did not include a search function, so indexing sites sprung up. Downloads for popular files tend to be faster than on many other networks. August – ShareReactor eDonkey network index site founded. It would be taken down by police in March 2004. September – Sony Music Entertainment admitted that they had included digital rights management software on Michael Jackson's You Rock My World single, perhaps the first such scheme to be implemented. October – Mutella client is released. By 2007, it would no longer be functional. October – Apple released the first iPod, which would eventually become the most popular portable mp3 player. October – Windows Media Player 8 includes the ability to rip CDs to mp3 for the first time.