In text-based internet communication, a posting style is the manner in which earlier messages are included or quoted. The concept applies to formats such as e-mail, Internet forums and Usenet.

The main options are interleaved posting (also called inline replying, in which the different parts of the reply follow the relevant parts of the original post), bottom-posting (in which the reply follows the quote) or top-posting (in which the reply precedes the quoted original message). For each of those options, there is also the issue of whether trimming of the original text is allowed, required, or preferred.

For a long time the traditional style was to post the answer below as much of the quoted original as was necessary to understand the reply (bottom or inline). Many years later, when email became widespread in business communication, it became a widespread practice to reply above the entire original and leave it (supposedly untouched) below the reply.

While each online community differs on which styles are appropriate or acceptable, within some communities the use of the "wrong" method risks being seen as a breach of netiquette, and can provoke vehement response from community regulars.

Quoting previous messages In an e-mail reply, it is sometimes appropriate to include a full or partial copy of the original message that is being replied to; due to the asynchronous nature of Internet communication, people often engage in many conversations at the same time, and email responses may be received long after the original message was sent. For these reasons, the original poster may not be aware of what message a post is intended to be a response to, and providing context is helpful. Many email reading programs (mail user agents) encourage this behaviour by automatically including a copy of the original message in the reply editing window.

Quoted text from previous messages is usually distinguished in some way from the new (reply) text. Often, the two parts are given different indentation. In the example below, the first paragraph is the original message, the second is the reply:

Hi Jim, could you confirm what time our meeting is tomorrow? -- Mary

It's at three o'clock. -- Jim

Alternatively, special delimiter lines may be used:

Yes Joe, I'll get onto that. --Mary

--- original message --- Could you send a copy of the report to our Paris office? --Joe --- end of original message ---

For extra clarity, blank lines may also be inserted between the two parts. When using an email medium that supports text markup (such as HTML or RTF), the previous text may be indicated by a distinctive font and/or color:

The meeting has been postponed to next Friday. --Mary

Has the deadline for the report been moved too? --Joe

Quoted line prefix

A common convention in plain-text email is to prefix each line of the quoted text with a distinctive character or string. As of 2020 (and for many years previously), the greater-than sign (">", the canonical prefix)R. Gellens (February 2004), RFC 3676 The Text/Plain Format and DelSp Parameters is almost universally used; but other characters such as the ASCII vertical bar character ("|") have been used as well, sometimes with one or more spaces inserted before or after the quoted text marker.

There is no standard declaring one quote-prefix to be "right" and others to be "wrong", but some standards depend on conventional quoting. The "never issued" and obsolete "son-of-1036" draft RFC 1849 recommends ">" as the quote-prefix; RFC 3676 depends on it and considers ">> " and "> > " to be semantically different. That is, ">> " has a quote-depth of two, while "> > " has a quote-depth of one, quoting a line starting with ">". Most e-mail clients treat the two sequences as equivalent, however.

The convention of quoting was common in Usenet newsgroups by 1990, and is supported by many popular email interfaces, either by default or as a user-settable option. In Microsoft Outlook, for instance, this behavior is controlled by an option labeled "Prefix each line of the original". Besides inserting markers automatically in quoted lines, some interfaces assume that a line starting with a ">" character or similar is quoted text, and will automatically display it in a distinctive font or color:

> How is the report coming? --Mary It will be on your desk by noon. --Joe

Sometimes the insertion of a quoted line marker will cause one original line to be folded as two lines in the reply, and the continuation line may not have the proper marker. To avoid ambiguity in such cases, one may consider inserting blank lines after each block of quoted text:

> The board is asking again for the sales data. We really must provide > them with some figures. How is the report coming? --Mary

It will be on your desk by noon. --Joe

Quoted line markers are most commonly used in plain-text messages. In HTML messages, other devices may be used to indicate quoted text, such as HTML indentation elements like blockquote or dl.

Reply level indication A message often includes text from two or more messages exchanged in previous rounds of a long discussion. If an additional quotation marker is inserted at every round, without removing any existing markers, the number of markers at the beginning of each line will show the "level" of the reply, that is, how many rounds have occurred since that line was written. These accumulated markers are usually sufficient to distinguish the parts that came from each message. Some email interfaces recognize this convention and automatically render each level in a different color. For example:

>>> How is the report coming? --Mary >> >> It will be on your desk by noon. --Joe > > Sorry Joe, I need it by 11:00 at the latest. --Mary

OK, but it will be missing this month's figures. --Joe

If the discussion is between two parties only, then an even number of markers (including zero) identifies text written by the sender, while an odd number of markers identifies text by the recipient. (In the above example even numbers are Joe's text and odd numbers are Mary's.)

No problem. 6pm it is then. --Jim

At 10.01am Wednesday, Danny wrote: > Whoa! I need to email a report at 5:30. > Could you push it back an hour? --Danny > > At 9.40am Wednesday, Jim wrote: > >> I'm going to suspend the mail service for approx. thirty >> minutes tonight, starting at 5pm. --Jim

In HTML messages, blockquote or dl elements may be nested to achieve the same effect.

Attribution lines Quoted material is often preceded by an attribution line that identifies its author. These lines are particularly helpful in discussions between multiple parties. For example:

Nancy wrote: > Peter wrote: >> When will we have the performance figures? > The tests will be completed next week.

Peter wrote: > Mary wrote: >> We should meet today to discuss the marketing strategy. > Better wait, we do not have the West Coast sales data yet.

I agree with Peter. We need the sales data and also Nancy's performance figures. Let's meet next Friday after lunch.

This reply quotes two messages, one by Nancy (itself a reply to Peter) and one by Peter (itself a reply to Mary).

Many mail agents will add these attribution lines automatically to the top of the quoted material. Note that a newly added attribution line should not get the quotation marker, since it is not part of the quoted text; so that the level indicator of the attribution line is always one less than the corresponding text. Doing otherwise may confuse the reader and also e-mail interfaces that choose the text color according to the number of leading markers.

Instead of an attribution line, one may indicate the author by a comment in brackets, at the beginning of the quotation:

>> [Peter:] When will we have the performance figures? > [Nancy:] The tests will be completed next week. >> [Mary:] We should meet today to discuss the marketing strategy. > [Peter:] Better wait, we do not have the West Coast sales data yet.

I agree with Peter. We need the sales data and Nancy's performance figures. Let's meet next Friday after lunch.

Another alternative, used in Fidonet and some mail user agents, is to place the initials of the author before the quoting marker. This may be used with or without attribution lines:

Nancy wrote: N> Peter wrote: P>> When will we have the performance figures? N> The tests will be completed next week.

Peter wrote: P> Mary wrote: M>> We should meet today to discuss the marketing strategy. P> Better wait, we do not have the West Coast sales data yet.

I agree with Peter. We need the sales data and also Nancy's performance figures. Let's meet next Friday after lunch.

Trimming and reformatting When replying to long discussions, particularly in newsgroup discussions, quoted text from the original message is often trimmed so as to leave only the parts that are relevant to the reply—or only a reminder thereof. This practice is sometimes called "trim-posting" or "edited posting", and is recommended by some manuals of posting etiquette.S. Hambridge (October 1995), Network Working Group RFC 1855 [rfc:1855 Netiquette Guidelines]

Sometimes an indicator of deleted text is given, usually in the form of a square bracketed tag as: "[snipped]", "[trimmed]", or simply "[...]". The text that is retained may be edited to some extent, e.g. by re-folding the lines. For example, if the original message was

This is a reminder that the project meeting which was canceled last week will be held today in the 3rd floor conference room at 14:30 sharp. Everybody must attend. --Mary

the reply may be > the project meeting [...] will be held today in the 3rd floor > conference room Mary, be sure to check the mics in that room. --Joe or even just > 3rd floor conference room Mary, be sure to check the mics in that room. --Joe Deleted text may also be replaced by a summary in brackets: On Thursday, Jim wrote: > The movie clearly adds a sense of menace to the story > which is not present in the original book. > [...claim that the darker tone weakens the movie...]

I disagree. The darker tone works well, once one understands the two are aimed at different audiences. Automatically included text (such as signature blocks, free e-mail service ads, and corporate disclaimers) are more likely to be deleted, usually without ellipses, than manually written text. Some posters may delete any parts of the original message that they are not replying to. Some posters delete only parts dealing with issues that they see as "closed", and leave any parts that, in their opinion, deserve further discussion or will be replied to in a later message.

How much to trim Some style guides recommend that, as a general rule, quoted material in replies should be trimmed or summarized as much as possible, keeping only the parts that are necessary to make the readers understand the replies. That of course depends on how much the readers can be assumed to know about the discussion. For personal e-mail, in particular, the subject line is often sufficient, and no quoting is necessary; unless one is replying to only some points of a long message.

In particular, when replying to a message that already included quoted text, one should consider whether that quoted material is still relevant. For example:

>> [Mary:] Shall we meet this afternoon to discuss the >> marketing strategy? > > [Peter:] Perhaps, if we can get all the information we need. > Do we have the West Coast sales data yet?

The LA office just sent them in. Joe

The quote from Mary's message is relevant to Peter's reply, but not to Joe's reply. The latter could have been trimmed to > [Peter:] Do we have the West Coast sales data yet?

The LA office just sent them in. Joe